Welcome to Mediachase Community Sign in | Join | Help    
in Search   

File Upload stopped working - Request Aborted Exception

Last post Sun, Mar 01 2009, 11:09 PM by Oleg Zhuk. 3 replies.
Sort Posts: Previous Next
  •  Fri, Feb 20 2009, 7:56 PM 10796

    File Upload stopped working - Request Aborted Exception

    Hello,

    My client just recently purchased the FileUploader.NET 2.0 control to upgrade their upload application. I am the developer working on the upgrade.

    Their new server is a Windows 2008 Server (64bit). After some trial and error we were able to get the file upload working, but it seemed to not allow very large uploads from external clients (more than 100mb roughly). Our system stores files in temp folder on D: drive and then the app sends the files to another ticket server after uploading is complete. This system worked before (on Win 2003 machine with v1.8) and worked briefly on the new server after fiddling with some .Net configurations and recoding (Win 2008 machine with v2.0).

    We also recently installed WSUS on the same machine

    Now, after installing WSUS, we can upload any files internally from the LAN but any other uploads from external sources that are larger than a few 100kb generate an Event Log error:

    Event code: 3005
    Event message: An unhandled exception has occurred.
    Event time: 2/20/2009 9:33:02 PM
    Event time (UTC): 2/21/2009 3:33:02 AM
    Event ID: 616ece5aa0ef4e9883562c9bf7ab53d7
    Event sequence: 1003
    Event occurrence: 2
    Event detail code: 0
     
    Application information:
        Application domain: /LM/W3SVC/3/ROOT-3-128796603876724285
        Trust level: Full
        Application Virtual Path: /
        Application Path: C:\inetpub\CustomerTickets\
        Machine name: RUBY2
     
    Process information:
        Process ID: 5972
        Process name: w3wp.exe
        Account name: NT AUTHORITY\NETWORK SERVICE
     
    Exception information:
        Exception type: Exception
        Exception message: Reqest was aborted
     
    Request information:
        Request URL: http://XXXX.XXXXXX.com/uploadiframe.aspx?SessionUid=c6ae7f70-46e1-47d2-a2f0-d57f8bbbc331&TempFileStorageProvider=McLocalDiskTempFileStorageProvider
        Request path: /uploadiframe.aspx
        User host address: 173.89.XX.XX
        User: 
        Is authenticated: False
        Authentication Type: 
        Thread account name: NT AUTHORITY\NETWORK SERVICE
     
    Thread information:
        Thread ID: 4
        Thread account name: NT AUTHORITY\NETWORK SERVICE
        Is impersonating: False
        Stack trace:    at Mediachase.FileUploader.McHttpModule.Application_BeginRequest(Object source, EventArgs e)
       at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
       at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

    We are running it in .Net 2.0 Classic (no 32bit apps enabled)
    Here is our Web Config:

    <configuration>
     <!-- Addon for <Mediachase.FileUploader.McHttpModule -->
     <configSections>
      <sectionGroup name="mediachase.fileUploader" type="Mediachase.FileUploader.Configuration.MediachaseFileUploaderSectionGroup, Mediachase.FileUploader">
       <section name="fileUploaderContext" type="Mediachase.FileUploader.Configuration.FileUploaderContextSection, Mediachase.FileUploader"/>
       <section name="tempFileStorage" type="Mediachase.FileUploader.Web.Configuration.TempFileStorageSection, Mediachase.FileUploader"/>
       <section name="uploadProgress" type="Mediachase.FileUploader.Web.Configuration.UploadProgressSection, Mediachase.FileUploader"/>
       <section name="fileUploadControl" type="Mediachase.FileUploader.Web.Configuration.FileUploadControlSection, Mediachase.FileUploader"/>
      </sectionGroup>
     </configSections>
     <connectionStrings>
      <add name="MGIDataConnectionString" connectionString="Data Source=XXXXXX;Initial Catalog=MGIData;Persist Security Info=True;User ID=xxxxx;Password=xxxxxxx" providerName="System.Data.SqlClient"/>
     </connectionStrings>
     <mediachase.fileUploader>
         <fileUploaderContext />

      <tempFileStorage defaultProvider="McLocalDiskTempFileStorageProvider" enabled="true" timeout="600">
       <providers>
        <add name="McLocalDiskTempFileStorageProvider" type="Mediachase.FileUploader.Web.LocalDiskTempFileStorageProvider, Mediachase.FileUploader" tempStoragePath="D:\uploadtempfolder"/>
       </providers>
      </tempFileStorage>
      <uploadProgress defaultProvider="McInProcessProgressStateProvider" enabled="true" timeout="60">
       <providers>
        <add name="McInProcessProgressStateProvider" type="Mediachase.FileUploader.Web.InProcessUploadProgressProvider, Mediachase.FileUploader" description=""/>
       </providers>
      </uploadProgress>
     </mediachase.fileUploader>
     <system.web>
      <trust level="Full" originUrl=""/>
      <httpRuntime executionTimeout="7200" maxRequestLength="409600"/>
        <httpModules>
          <add name="Mediachase.FileUploader.McHttpModule" type="Mediachase.FileUploader.McHttpModule, Mediachase.FileUploader"/>
        </httpModules>
        <httpHandlers>
          <add verb="GET" path="McFileUploaderResources.axd" type="Mediachase.FileUploader.AssemblyResourceHandler, Mediachase.FileUploader" />
        </httpHandlers>
      <compilation debug="true">
       <assemblies>
        <add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
        <add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/></assemblies></compilation></system.web>
     
     <system.codedom>
      <compilers>
          <compiler language="c#;cs;csharp" extension=".cs" type="Microsoft.CSharp.CSharpCodeProvider,System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" warningLevel="1">
          </compiler>
      </compilers></system.codedom>
     <system.webServer>
      <modules>
       <add name="Mediachase.FileUploader.McHttpModule" type="Mediachase.FileUploader.McHttpModule, Mediachase.FileUploader"/>
      </modules>
      <security>
       <requestFiltering>
        <requestLimits maxAllowedContentLength="2000000000"/>
       </requestFiltering>
      </security>
     </system.webServer>
    </configuration>


    Any advice?

  •  Tue, Feb 24 2009, 12:46 AM 10819 in reply to 10796

    Re: File Upload stopped working - Request Aborted Exception

    Check Application Pool restart timeouts in IIS.

    If IIS recycles the Application Pool in IIS during an upload, the "Request Reqest was aborted" error message is shown on screen, because IIS have closed connections and gone to new pool.
  •  Thu, Feb 26 2009, 1:21 PM 10851 in reply to 10819

    Re: File Upload stopped working - Request Aborted Exception

    Timeout is set at 1740 minutes. They are using standard IIS7 defaults.

    When I click upload, I can see a 0byte file (and 1byte file) created in the Temp Folder.. after a few seconds a second 0 byte file set is created... after a few more seconds a third file set is created and then I get an "Internet Explorer has stopped working" error.

    Tried using Firefox 3, IE7, and IE8

    Update:  When I try and upload from a different location, I get different results. When I upload a small file it seems to work OK. When I upload something large than around 150mb it fails with a different error.

  •  Sun, Mar 01 2009, 11:09 PM 10871 in reply to 10851

    Re: File Upload stopped working - Request Aborted Exception

    Verify, In IIS 7 on Windows 2008 Server, the web application will reject any file that is larger than 30 MB. This is a default limitation of IIS. You can increase the maximum file size by adding the following code to <system.webServer> in the web.config file:

    <security>
     <requestFiltering>
      <requestLimits maxAllowedContentLength=”2000000000″ />
     </requestFiltering>
    </security>

    I saw that your config already includes  requestLimits limit but re-check real config and check max file size that you can successfully upload to server.
    Also you can create a simple post form with file input and button, turn off FileUploader.Net handler and try to upload file to server again. Does IIS show you error?

    PS: Send me to ozh@mediachase.ru your Mediachase.FileUploader.dll.
View as RSS news feed in XML
Site Terms | Privacy Policy | About Us | Contact Us
Running on Mediachase eCommerce Framework 4.0.
  Copyright © Mediachase, LTD. 1997-2006. All Rights Reserved

E-commerce, HelpDesk, Service Desk & Project Management Software, alternatives to Microsoft Project Server & Sharepoint Collaboration Server
project management software | microsoft project server | sharepoint collaboration server | issues management, helpdesk & service desk
Powered by Community Server, by Telligent Systems